• Services
    Training

    Cyber Security training is imperative for all staff from board level members through to HR and even to upskill IT teams. At North Star we provide an enjoyable learning experience with training from awareness level to bespoke technical training courses.

Accredited Managed Security Service Provider you can rely on

North Star Cyber Security are a CREST accredited company for Penetration Testing. An IASME certification body for Cyber Essentials, Cyber Essentials Plus and IASME Governance. A supplier on G-Cloud and the Digital Marketplace and a supporter of the HM Armed Forces.

Cyber Essentials Certifed               

Employee Awareness

Over 90% of cyber attacks are due to human error. All too often CEOs confronted with cyber-attacks tend to fret about possible weaknesses in their technology defences, rather than taking a hard look at the people in their organisation.
Read more

Board Level

Our Board-level training provides Boards with an understanding of Cyber Security, what this means for their organisation, themselves and their staff. Boards will be provided with the latest Threat briefing; an understanding of responsibilities, liabilities and consequences of breach, including key legislation, business information risk management; building resilience and capability.
Read more

Penetration Testing

Penetration testing is a process of scanning and searching for vulnerabilities in your applications or networks. It is designed to test your systems the way an attacker would, finding any weaknesses before criminals or hackers can exploit them.
Read more about our Penetration Testing Course

Cyber Fundamentals

Does your organisation need to learn the basics of cyber security or want to train staff in technical areas? North Star’s Cyber Security will provide your staff with a solid fundamental knowledge of the current cyber threats, cyber security terminology and how to protect your company.
Read more

Securing your business together

View our qualifications, accreditations and partnerships below